Aditya Gupta asked 1 year ago
Title : Custom MTA not processing

Question :

Custom MTA is not processing more than 500 records I have verified below entries in pin.conf

  1. per step :100
  2. children :3
  3. per batch:50
  4. fetch size:500
1 Answers
Umesh SharmaUmesh Sharma Staff answered 1 year ago

The error is due to the usage of PIN_FLD_TAKE instead of PIN_FLD_GET function. The function PIN_FLD_TAKE removes the parameter from the source flist. Due to which a field in an flist is missing and hence the batches proceeding the first batch of 500 will get an error for the same. For example,  crit = PIN_FLIST_FLD_TAKE(app_flistp, PIN_FLD_CRITERION, 0, ebufp);  This function will take the field PIN_FLD_CRITERION from the flist in the first batch and the field will be unavailable for the remaining batches. Hence we should use crit = PIN_FLIST_FLD_GET(app_flistp, PIN_FLD_CRITERION, 0, ebufp);

Cubastion is among a very small number of specialized Siebel CRM Oracle Gold Partners in SME.